Saturday, September 18, 2010

NetBook Upgrade

imageI decided to upgrade my Samsung N130 NetBook today from the rather basic Windows 7 Starter Edition  to the more substantial Windows 7 Home Premium. It was a bit of a gamble as the spec on the NetBook was a bit below that recommended by Microsoft. I did it because the networking capabilities with non-Win7 machines is somewhat limited with Starter and I wanted to hook it up to the rest of the home network.

The upgrade process itself was pain-free, as it runs from within the NetBook itself, so no massive files to download. Hmmm, I wonder if the files are already stored on the machine and just get ‘unlocked’ when you upgrade. Five minutes and £70 later, I had a few more whistles and bells that I didn’t have before. And, paradoxically, the machine seemed to be a bit faster too – that’s weird because, if anything, it should be a tad slower trying to handle the extra graphics grunt of the aero theme.
Open-mouthed smile Open-mouthed smile Open-mouthed smile 

So far, so good. Now the moment of truth – would the rest of the network ‘see’ the NetBook and could I print to the wireless printer on the network? Well, the other XP machines DID see the NetBook, so that’s good, but the NetBook COULDN’T see the XP machines – that’s bad!!! To add to my woes, clicking on the NetBook icon on any other machine, popped up a message ‘can’t access..make sure you have permission...’

The NetBook couldn’t ‘find’ the NAS device either.
Steaming mad Steaming mad Steaming mad 

A quick Google of my problem revealed a gazillion people with the same issue – with no apparent solution! Looks like a busy weekend then trying to sort all this out!! C’mon Microsoft, it shouldn’t be that hard!! I’m lucky that I’m quite good with PCs, but the average punter has no chance of resolving this – it should just work ‘out-of-the-box’ shouldn’t it? shouldn’t it!!!

Steaming mad Steaming mad Steaming mad

Ho-hum.... I guess I need to keep looking for a solution!!!!

Update: 2.30pm I changed the AVG Firewall profile to ‘allow all’ as opposed to ‘directly connected to the Internet’, and all the PCs on the network suddenly showed up – but that’s not a long-term solution, so I’ve emailed a diagnostics report to AVG as it’s obviously a firewall issue. I still can’t get any app on the NetBook to ‘see’ the Canon MP640 printer though.

Update: 5.30pm I’ve changed the AVG Firewall Profile to ‘Computer in Domain’ and added a line to the Registry called IRPStackSize and given it a value of 17. Looking further around the ‘net, the latter seemed to be the popular solution. Not sure how and why these two changes made a difference, but I can now see the other PCs on the network AND I can access the NAS Stora.
Winking smile Winking smile 

So, I’m getting there – just need to try and solve the printer problem now!

Update: 11.30pm OK, the final part of the jigsaw is now solved as I’ve managed to get the NetBook talking to the wireless printer. As any well respecting Windows-nerds know, if the printer is shared across a network, you don’t normally have to install the driver software on the PC in question – Windows senses the printer is there, and auto-installs any drivers. Spookily, on the NetBook, this didn’t happen (I suspect it’s something to do with Windows 7). I downloaded fresh drivers from the ‘net and installed them - and hey-presto, apart from an annoying error message about ‘bi-directional printing’, it’s all working fine.

...and so to bed, with a smug smile on my face!!!!
Smile Smile Smile Smile Smile

Update: Monday 2.30pm I think this was more a fluke than conscious effort, but I seem to have got the bi-directional part of the Canon MP640 wireless printer working. How? Well, I downloaded the latest drivers from the Canon US web-site AND having read somewhere that the Firewall might be interfering, I turned it off during installation.- now everything is working fine!!!